Thursday 13th July 2017

update.ets2mp.com and launcher unable to update

No further issues have been observed.

Issue was related to a physical machine at our provider dying.

We will be ensuring that we have backups and machines ready to go should this occur again.